Mise à jour vers WordPress 5.2 et passage à PHP 7

Partager sur facebook
Facebook
Partager sur google
Google+
Partager sur twitter
Twitter
Partager sur linkedin
LinkedIn

Pour des raisons de sécurité, la version 5.2 de WordPress demande maintenant un passage à PHP 7 (idéalement 7.2 ou 7.3).

Cela est une vraie nécessité pour tous les sites WordPress : les performances sont fortement améliorées (pages chargées plus vite, etc) et la sécurité est accrue.

En cas de problème majeur, il est également possible de continuer sur PHP 5.2.4. Sans quoi, impossible de mettre à jour votre installation, ce qui vous expose a d’autant plus de risques de sécurité à l’avenir.

Aujourd’hui, la plupart des plugins WordPress ont été revu pour être compatibles avec ces dernières versions de PHP, ce qui limite les risques de dysfonctionnement lors du passage à la dernière version.

Les thèmes sont plus susceptibles de vous poser problème : étant moins sujets aux mises à jour par les utilisateurs (cela est parfois complexe), ils ne seront pas nécessairement compatible avec PHP 7. Dans ce cas, une analyse précise de votre thème et des fonctions bloquante doit être réalisée : si la mise à jour n’est pas possible, il est parfois possible de contourner les blocages.

Comment effectuer le changement de version de PHP ?

Cela se réalise généralement du côté de votre hébergeur.

Articles similaires

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *